What is the difference between Telnet and SSH as supported by a Cisco switch?

that commands that follows apply to to all 16 possible concurrent virtual terminal connections to the switch,which includes telnet as well as SSH access"

My understanding is , given the above config, ssh access is not possible as ssh access requires atleast username and password be confgured . So basically the above config is only valid for telnet. But the excerpt from the book, quoted above,says ( the last line) the above config apply to both telnet and ssh.

========================================

Please consider the following config:

2) line vty 0 15

login local

transport input telnet ssh

username sarah password cisco

crypto key generate rsa

my question is if i have to telnet to this switch, will i be prompted for username and password? or i will be prompted for username and password only if i connect via ssh?

First of all, I'm having trouble connecting to my 2950 using Telnet/SSH, though I've applied a VTY password.  As an aside, I'm able to connect through the console.  I applied an IP address to the switch, and I'm wondering if there's a part of the process that I've missed.  When using Putty to connect to the IP, I immediately receive the "Network Error: Connection refused" error; the same basic message happens, using Tera Term.  

Here's my running config:


Switch#show running-config
Building configuration...

Current configuration : 2416 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
no logging console
!
username CCNA password 0 CCIE
ip subnet-zero
!
ip domain-name modeofinquiry.com
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport mode access
!
interface FastEthernet0/2
 switchport mode access

" " " " " " " " 

" " " " " " " "
interface FastEthernet0/24
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan2
 ip address 192.168.1.107 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
!
line con 0
 exec-timeout 0 0
 password CCENT
 logging synchronous
 login
line vty 0 4
 login local
 transport input telnet ssh
line vty 5 15
 login local
 transport input telnet ssh
!
!
end
 --More--

The physical connection I'm using is from my desktop's second NIC, and I've configured the IPv4 connection to the switch's listed IP, which is 192.168.1.107.  Is there anything listed above that would be problematic?

One of my questions has to do with the IP address that's supposed to be used to receive rsa keys: why is it necessary?  Also, I tried entering the "ip address dhcp" command to grab an address from my WRT54G and received the following:


Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan2
Switch(config-if)#ip address dhcp
                             ^
% Invalid input detected at '^' marker.

I'm following the directions in Odom's book, and I don't see what I'm missing.  

My other question has to do with passwords, in general.  Entering the username/password on either the interface-subcommand or the global configuration area seems unimportant, here:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#line vty 0 15
Switch(config-line)#login local
Switch(config-line)#transport input ssh telnet
Switch(config-line)#username DDDD password EEEE
Switch(config)#^Z

...and...

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#line vty 0 15
Switch(config-line)#login local
Switch(config-line)#transport input ssh telnet
Switch(config-line)#exit
Switch(config)#username FFFF password GGGG
Switch(config)#^Z

Here's the running config, afterwards:

Switch#show running-config
Building configuration...

Current configuration : 2535 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
no logging console
!
username CCNA password 0 CCIE
username BBBB password 0 CCCC
username DDDD password 0 EEEE
username FFFF password 0 GGGG
ip subnet-zero
!
ip domain-name modeofinquiry.com
ip ssh time-out 120
ip ssh authentication-retries 3
!
 --More--

It doesn't appear as though exiting out of config-if mode made any difference for the usernames/passwords.  Then again, I can't connect through Telnet/SSH, so I'm not able to test it, at the moment.  

I'm really sorry for the huge post, but I didn't want to start multiple threads.  Any help is much appreciated.

What is the difference between SSH and Telnet?

The most significant difference between SSH and Telnet is that Telnet transfers the data in the form of simple plaintext, whereas SSH uses encrypted format for data transmission and also it uses a secure channel.